TLS 1.0 & 1.1 Deprecation FAQs

ActiveCampaign is ending support for all API requests from servers using TLS 1.0 and 1.1 on May 3, 2019. Here’s what you need to know.

What is TLS?

Transport Layer Security (TLS) is a security protocol that is used to secure communications over the internet. TLS ensures that there is an adequate level of security, data privacy, and data integrity between two computer applications.

There are currently four versions of the TLS protocol in use today: TLS 1.0, 1.1, 1.2, and 1.3.

TLS 1.0. and 1.1 are outdated versions of the protocol that are less secure than TLS 1.2 and 1.3.

Why do I need to upgrade my TLS settings?

1.2 is the current industry standard of the TLS security protocol. Since this protocol is used to encrypt your servers’ communications with ActiveCampaign and our integration partners, it’s important that your TLS settings remain up-to-date. We are ending support for all API requests to ActiveCampaign from servers using TLS 1.0 and 1.1 on May 3, 2019.

If you do not upgrade to TLS 1.2 or higher by end of day May 2, 2019, your API calls will fail after that date. This means that any integrations or other components of your business utilizing ActiveCampaign’s API will not run after April 30.

How do I learn which version of TLS I’m using?

You can run a command on your server to learn whether or not you are using an outdated version of TLS. If you run the command “openssl version” on your server and it returns 1.0.1 or higher, you are using a current, secure version of TLS.

Here are some examples:

Command: “openssl version”

Example return from a Mac: “LibreSSL 2.6.5”

Example return from a Linux machine: “OpenSSL 1.0.2k-fips  26 Jan 2017”

In these examples, you would not need to upgrade because the return is higher than 1.0.1, which means you are using an up-to-date version of TLS.

For third parties such as Zapier or WordPress, you'll need to reach out to their support teams to verify that they are using a current version of TLS.

How do I upgrade my TLS settings?

Exact upgrade steps and TLS settings will vary based on your development environment and configuration. If you work with a developer, they can take care of the upgrade for you.

Please contact our Support team with any additional questions.

What happens if I don’t upgrade my TLS settings by April 30?

If you do not upgrade to TLS 1.2 or higher by end of day May 2, 2019, your API calls will fail after that date. This means that any integrations or other components of your business utilizing ActiveCampaign’s API will not run after May 2.

Can I get an extension?

We understand that this change could potentially be disruptive to your business if not made before the May 2 deadline, which is why we are working to provide as much advance notice as possible. While we cannot offer an extension, we encourage you to consult with a developer for assistance and reach out to Support with any additional questions.

Have more questions? Submit a request