Preguntas frecuentes sobre desuso TLS 1.0 y 1.1

ActiveCampaign finaliza la compatibilidad con todas las solicitudes de API de servidores que usan TLS 1.0 y 1.1 el 31 de mayo de 2019. Esto es lo que necesitas saber.

¿Qué es TLS?

Transport Layer Security (TLS) es un protocolo de seguridad que se utiliza para proteger las comunicaciones a través de Internet. TLS garantiza que haya un nivel adecuado de seguridad, privacidad de datos e integridad de datos entre dos aplicaciones informáticas.

Actualmente hay cuatro versiones del protocolo TLS en uso hoy en día: TLS 1.0, 1.1, 1.2 y 1.3.

TLS 1.0. y 1.1 son versiones obsoletas del protocolo que son menos seguras que TLS 1.2 y 1.3.

¿Por qué necesito actualizar mi configuración de TLS?

1.2 es el estándar actual de la industria del protocolo de seguridad TLS. Dado que este protocolo se utiliza para cifrar las comunicaciones de sus servidores con ActiveCampaign y nuestros socios de integración, es importante que la configuración de TLS permanezca actualizada. Estamos finalizando la compatibilidad con todas las solicitudes de API a ActiveCampaign desde servidores que usan TLS 1.0 y 1.1 el 1 de junio de 2019.

Si no actualiza a TLS 1.2 o superior al final del día 31 de mayo de 2019, se producirá un error en las llamadas a la API después de esa fecha. Esto significa que las integraciones u otros componentes de su negocio que utilicen la API de ActiveCampaign no se ejecutarán después del 31 de mayo.

¿Cómo puedo saber qué versión de TLS estoy usando?

Puede ejecutar un comando en el servidor para saber si está utilizando o no una versión obsoleta de TLS. Si ejecuta el comando "openssl version" en el servidor y devuelve 1.0.1 o superior, está utilizando una versión actual y segura de TLS.

Estos son algunos ejemplos:

Comando: "versión openssl"

Ejemplo de devolución de un Mac: "LibreSSL 2.6.5"

Ejemplo de retorno de una máquina Linux: "OpenSSL 1.0.2k-fips 26 ene 2017"

En estos ejemplos, no necesitaría actualizar porque el retorno es mayor que 1.0.1, lo que significa que está utilizando una versión actualizada de TLS.

Para terceros como Zapier o WordPress, deberás ponerte en contacto con sus equipos de soporte para verificar que están usando una versión actual de TLS.

¿Cómo actualizo mi configuración de TLS?

Los pasos exactos de actualización y la configuración de TLS variarán en función del entorno de desarrollo y la configuración. Si trabaja con un desarrollador, pueden encargarse de la actualización para usted.

Póngase en contacto con nuestro equipo de soporte cualquier pregunta adicional.

¿Qué sucede si no actualizo mi configuración de TLS antes del 30 de abril?

Si no actualiza a TLS 1.2 o superior al final del día 31 de mayo de 2019, se producirá un error en las llamadas a la API después de esa fecha. Esto significa que las integraciones u otros componentes de su negocio que utilicen la API de ActiveCampaign no se ejecutarán después del 31 de mayo.

¿Puedo obtener una extensión?

Entendemos que este cambio podría ser potencialmente perjudicial para su negocio si no se hace antes de la fecha límite del 31 de mayo, por lo que estamos trabajando para proporcionar la mayor anticipación posible. Aunque no podemos ofrecer una extensión, le recomendamos que consulte con un desarrollador para obtener ayuda y póngase en contacto con de soporte con cualquier pregunta adicional.

¿Tiene más preguntas? Enviar una solicitud