Dépannage des problèmes de connexion pour l'intégration des données profondes de WooCommerce

Si vous'recevez un message d'erreur lors de la configuration de l'intégration des données approfondies de WooCommerce, il peut y avoir plusieurs raisons à cela. Dans cet article, nous allons énumérer les erreurs de connexion qui peuvent apparaître lors de la configuration de l'intégration des données profondes de WooCommerce et ce que vous pouvez faire pour les résoudre.

Erreur de connexion WooCommerce

Ce qu'il faut vérifier :

  • Votre protocole
    Certaines URL de magasins WooCommerce utilisent un protocole HTTP tandis que d'autres utilisent un protocole HTTPS. Vérifiez le protocole que vous utilisez. Selon la configuration de votre serveur, vous devrez peut-être essayer les deux protocoles pour voir lequel fonctionne.
  • Votre certificat SSL
    Votre certificat SSL peut présenter un problème. Vous devrez travailler avec l'administrateur de votre serveur, ou avec la personne qui a configuré le SSL, pour diagnostiquer et résoudre tout problème de certificat SSL. Vous pouvez également utiliser ce vérificateur SSL pour diagnostiquer tout problème lié à l'installation de votre certificat SSL.

L'API WooCommerce est mal configurée

Ce qu'il faut vérifier :

  • Votre API WooCommerce Rest est-elle activée ?  
    Dans le plugin WooCommerce de votre compte Wordpress, assurez-vous que la case « Activer l'API REST » est cochée. Si ce n'est pas le cas, cochez la case et cliquez "Save Changes." 
  • Configuration du lien permanent
    Les permaliens sont les URL permanentes de votre article de blog ou de votre page sur votre site WordPress. Vous devrez vous assurer qu'ils sont correctement configurés. Toutes les options de permalien dans l'encadré rouge de l'image ci-dessous fonctionneront, y compris : « Jour et nom », « Mois et nom », « Numérique », « Nom de poste » et « Structure personnalisée ».

    L'utilisation de l'option de permaliens « simples » ne fonctionnera pas avec cette intégration.
  • Votre fichier .htaccess 
    Vous devrez vous assurer que le fichier .htaccess de votre compte WordPress ne contient pas de règles de réécriture par défaut de WordPress :
RewriteRule ^index\.php$ - [L]
RewriteCond %[%1$s:REQUEST_FILENAME] !-f
RewriteCond %[%1$s:REQUEST_FILENAME] !-d
RewriteRule . /index.php [L]

La configuration liée au serveur peut affecter l'accès à votre site WordPress et aux points d'extrémité de l'API WooCommerce. Vous devrez peut-être consulter un administrateur de serveur si les problèmes persistent, ou consulter quelqu'un qui est familier avec la maintenance ou le dépannage de la configuration de votre serveur web.

Le plugin WooCommerce n'a pas été détecté

Ce qu'il faut vérifier :

  • Votre plugin WooCommerce dans votre installation WordPress
    Assurez-vous que le plugin WooCommerce WordPress est installé et activé dans votre compte WordPress.

URL WooCommerce invalide

Ce qu'il faut vérifier :

  • L'URL de votre magasin
    Assurez-vous que l'URL du magasin que vous avez utilisé pour mettre en place l'intégration Deep Data n'inclut pas "/shop" à la fin de l'URL du magasin. Par exemple :

    Correct : https://my-store.com
    Incorrect : https://my-store.com/shop

    Vous pouvez le vérifier dans votre compte ActiveCampaign en cliquant sur « Paramètres » puis « Intégrations ». Une fois là, cliquez sur l'intégration WooCommerce. À partir de là, vous devrez déconnecter votre magasin, puis le reconnecter en utilisant la bonne URL. 

Erreur inattendue

Dans de rares cas, cette erreur peut apparaître. Si vous constatez cette erreur, veuillez contacter notre équipe de soutien et nous vous aiderons à résoudre le problème de connexion.

Cet article vous a-t-il été utile ?

Have more questions? Submit a request

Essai gratuit