Domande frequenti sulla deprecazione di TLS 1.0 e 1.1

Marketing_Lite_Plus_Professional_Enterprise

Sales_Plus_Professional_Enterprise

ActiveCampaign terminerà il supporto per tutte le richieste API dai server che utilizzano TLS 1.0 e 1.1 il 31 maggio 2019. Ecco cosa devi sapere.

Che cos'è TLS?

Transport Layer Security (TLS) è un protocollo di sicurezza utilizzato per proteggere le comunicazioni su Internet. TLS garantisce un livello adeguato di sicurezza, privacy e integrità dei dati tra due applicazioni informatiche.

Attualmente sono in uso quattro versioni del protocollo TLS: TLS 1.0, 1.1, 1.2 e 1.3.

TLS 1.0. e 1.1 sono versioni obsolete del protocollo che sono meno sicure di TLS 1.2 e 1.3.

Perché è necessario eseguire l'upgrade delle impostazioni TLS?

1.2 è l'attuale standard industriale del protocollo di sicurezza TLS. Poiché questo protocollo viene utilizzato per crittografare le comunicazioni dei server con ActiveCampaign e i nostri partner di integrazione, è importante che le impostazioni TLS rimangano aggiornate. Il 1° giugno 2019 termineremo il supporto per tutte le richieste API ad ActiveCampaign dai server che utilizzano TLS 1.0 e 1.1.

Se non esegui l'upgrade a TLS 1.2 o versione successiva entro la fine del giorno 31 maggio 2019, le chiamate API avranno esito negativo dopo tale data. Ciò significa che qualsiasi integrazione o altro componente della tua attività che utilizza l'API di ActiveCampaign non verrà eseguito dopo il 31 maggio.

Come faccio a sapere quale versione di TLS sto usando?

È possibile eseguire un comando sul server per verificare se si utilizza o meno una versione obsoleta di TLS. Se si esegue il comando "openssl version" sul server e restituisce 1.0.1 o versione successiva, si sta utilizzando una versione corrente e sicura di TLS.

Ecco alcuni esempi:

Comando: "openssl version"

Esempio di ritorno da un Mac: "LibreSSL 2.6.5"

Esempio di ritorno da un computer Linux: "OpenSSL 1.0.2k-fips 26 gen 2017"

In questi esempi, non è necessario eseguire l'upgrade perché il ritorno è superiore a 1.0.1, il che significa che si sta utilizzando una versione aggiornata di TLS.

Per terze parti come Zapier o WordPress, dovrai contattare i loro team di supporto per verificare che stiano utilizzando una versione corrente di TLS.

Come si esegue l'upgrade delle impostazioni TLS?

I passaggi esatti per eseguire l'upgrade e le impostazioni TLS variano in base all'ambiente di sviluppo e alla configurazione. Se lavori con uno sviluppatore, può occuparsi di eseguire l'upgrade per te.

Contatta il nostro team Customer Experience per ulteriori domande.

Cosa succede se non eseguo l'upgrade delle mie impostazioni TLS entro il 30 aprile?

Se non esegui l'upgrade a TLS 1.2 o versione successiva entro la fine del giorno 31 maggio 2019, le chiamate API avranno esito negativo dopo tale data. Ciò significa che qualsiasi integrazione o altro componente della tua attività che utilizza l'API di ActiveCampaign non verrà eseguito dopo il 31 maggio.

Posso ottenere un'estensione?

Comprendiamo che questo cambiamento potrebbe potenzialmente essere dannoso per la tua azienda se non effettuato prima della scadenza del 31 maggio, motivo per cui stiamo lavorando per fornire il maggior preavviso possibile. Sebbene non possiamo offrire un'estensione, ti invitiamo a consultare uno sviluppatore per assistenza e contattare il nostro team Customer Experience per ulteriori domande.

Questo articolo ti è stato utile?
Utenti che ritengono sia utile: 4 su 9