Solução de problemas WooCommerce Problemas de conexão de integração de Deep Data

Se você estiver recebendo uma mensagem de erro ao configurar a integração de Deep Data do WooCommerce, podem haver alguns motivos. Neste artigo, listaremos erros de conexão que podem aparecer ao configurar a integração de Deep Data do WooCommerce e o que você pode fazer para soluciona-los.

Erro de conexão do WooCommerce

O que verificar:

  • Seu protocolo
    Alguns URLs da loja WooCommerce usam um protocolo HTTP, enquanto outros usam um protocolo HTTPS. Verifique duas vezes qual protocolo você está usando. Dependendo da configuração do servidor, talvez seja necessário tentar ambos os protocolos para ver qual funciona.
  • Seu certificado SSL
    Seu certificado SSL pode ter um problema. Você precisará trabalhar com o seu administrador do servidor, ou com o indivíduo que configurou o SSL, para diagnosticar e corrigir quaisquer problemas de certificado SSL. Você também pode usar este verificador SSL para diagnosticar quaisquer problemas com a instalação do certificado SSL.

API do WooCommerce configurado incorretamente

O que verificar:

  • Sua API Rest do WooCommerce está ativada?  
    Em seu plug-in WooCommerce em sua conta do Wordpress, certifique-se de que a caixa "Habilitar a API REST" seja verificada. Se não for, verifique a caixa e clique em "Salvar alterações".
  • Configuração do Permalink
    Permalinks são os URLs permanentes de seu post ou página de blog individual em seu site WordPress. Você precisará ter certeza de que eles estão configurados corretamente. Todas as opções de permalink na caixa vermelha na imagem abaixo funcionarão, incluindo: "Dia e nome", "Mês e nome", "Numérico", "Nome de postagem" e "Estrutura personalizada".

    O uso da opção permalinks "Simples" não funcionará com essa integração.
  • Seu arquivo .htaccess 
    Você precisará ter certeza de que o arquivo .htaccess em sua conta WordPress não inclua regras de reescrita padrão do WordPress:
RewriteRule ^index\.php$ - [L]
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule . /index.php [L]

A configuração relacionada ao servidor pode afetar o acesso ao seu site WordPress e aos endpoints da API do WooCommerce. Você pode precisar consultar um administrador do servidor se os problemas persistirem ou consultar alguém que esteja familiarizado com a manutenção ou solução de problemas da configuração do servidor web.

Plug-in WooCommerce não detectado

O que verificar:

  • Seu plug-in do WooCommerce na instalação do WordPress
    Certifique-se de que o plug-in WordPress do WooCommerce esteja instalado e habilitado em sua conta do WordPress.

URL do WooCommerce inválido

O que verificar:

  • URL da sua loja
    Certifique-se de que a URL da loja usada para configurar a integração Deep Data não inclua "/shop" no final da URL da loja. Por exemplo:

    Correto: https://my-store.com
    Incorreto: https://my-store.com/shop

    Você pode verificar isso em sua conta da ActiveCampaign clicando em "Configurações" depois em "Integrações". Uma vez lá, clique na integração WooCommerce. A partir daqui, você precisará desconectar sua loja e, em seguida, reconectá-la usando a URL correta. 

Erro inesperado

Em casos raros, esse erro pode aparecer. Se você vir esse erro, entre em contato com a nossa equipe de suporte e podemos ajudá-lo a resolver o problema de conexão.

Tem mais dúvidas? Envie uma solicitação